AMPPS 3.8

The Softaculous AMPPS Team has released AMPPS 3.8

New Features:

  • Added Apps section, user can now add, remove and update Apps like Apache, MySQL, PHP directly from Softaculous Enduser Panel.
  • Added option to close AMPPS directly i.e. without any prompt for confirmation. This option can be enabled from AMPPS Panel –> Options –> Settings–> Do not prompt for message while closing Ampps.
  • User can now open Configuration files in default editor instead of notepad. This option can be enabled from AMPPS Panel –> Options –> Settings –> Open Configuration file in default editor.
  •  Apache will restart automatically after adding Domain.
  •  All new versions of Apache, MySQL, PHP, MongoDB are added.
  • Ioncube Loader added for PHP 7.1.
  • Fixed minor bugs in AMPPS.

A complete list Apps update:

The current version of AMPPS for Windows include:

Softaculous 4.9.3,

Apache 2.4.27,
OpenSSL 1.1.0f,
PHP 7.1.8, PHP 7.0.22, PHP 5.6.31, PHP 5.5.38, PHP 5.4.45 and 5.3.29,
ionCube PHP Loader v 10.0.0, Xdebug 2.5.5,
PERL 5.16.3,
Python 3.6.2 with mod_wsgi 4.5.17 module,
MySQL 5.6.37,
phpMyAdmin 4.4.15.7,
SQLite Manager 1.2.4,
MongoDB 3.4.7,
RockMongo 1.1.7,
FileZilla FTP Server 0.9.44,

The current version of AMPPS for Mac include:

Softaculous 4.9.3,

Apache 2.4.27,
OpenSSL 1.1.0f,
PHP 7.1.8, PHP 7.0.22, PHP 5.6.31, PHP 5.5.38, PHP 5.4.42 and 5.3.29,
ionCube PHP Loader v 10.0.0, Xdebug 2.5.5,
PERL 5.26.0,
Python 3.6.2 with mod_wsgi 4.5.17 module,
MySQL 5.6.37,
phpMyAdmin 4.4.15.7,
SQLite Manager 1.2.4,
MongoDB 2.6.7,
RockMongo 1.1.7,
Pure-FTPd Server 1.0.36,

The current version of AMPPS for Linux include:

Softaculous 4.9.3,
Apache 2.4.27,
OpenSSL 1.0.1t,
PHP 7.1.1, PHP 7.0.22, PHP 5.6.31, PHP 5.5.38, PHP 5.4.45 and 5.3.29,
ionCube PHP Loader v10.0.0, Xdebug 2.5.5,
PERL 5.26.0,
Python 3.6.2 with mod_wsgi 4.5.17 module,
MySQL 5.6.37,
phpMyAdmin 4.4.15.5,
SQLite Manager 1.2.4,
MongoDB 3.4.7,
RockMongo 1.1.7,
Pure-FTPd Server 1.0.36,

Regards,
The Softaculous AMPPS Team

Softaculous 4.9.3

The Softaculous Team has released Softaculous 4.9.3 for AMPPS.

1) Revamped Admin panel UI. The new UI is based on Bootstrap and is responsive.

2) Added Show/Hide option for password fields.

3) Added option in Softaculous enduser panel to import installations from Remote servers. Refer to the guide here.

4) Added option in admin panel to show only the parent version for scripts having multiple branches.

5) Added a notice on backups page in Softaculous Enduser panel to notify the enduser about the maximum backups limit set by admin.

6) Added option in Softaculous Admin panel to disable Remote Import option for endusers.

7) Added option to install WordPress themes from the Edit Installation page in Softaculous Enduser panel.

8) Script Logos in Softaculous Enduser panel will now be loaded from the server itself instead of Softaculous Mirror servers thus making the logos load faster.

9) [Task] : Improved Softaculous Update page in Softaculous Admin panel.

10) [Task] : Improved the Cloning process by pushing it in background to avoid timeout.

11) [Bug Fix] : Script Install API did not work in rare cases when the password had some special characters. This has been fixed now.

12)[Bug Fix] : In some cases the database password was encrypted twice causing the backups, auto upgrade to fail. This has been fixed now and the installations that were already affected will be handled with the fix. This issue occurred only if the Server admin had enabled “Store Database Password in encrypted format” option from Softaculous Admin panel.

13) [Bug Fix] : Backup Notes having special characters like ‘ and ” did not return correct values in List Backups API call. This is fixed now.

14) [Bug Fix] : Auto Backups Rotation option was available on Edit Installation page in Softaculous even if Auto Backups was disabled by admin. This is fixed now.

15) [Bug Fix] : On Softaculous Admin panel -> Software page the Select All (Category) checkbox did not work for categories having only one script. This has been fixed now.

16) [Bug Fix] : Import Software page had JavaScript error when selecting domain from Choose Domain dropdown. This has been fixed.

17) [Bug Fix] : Users were not able to update the installation details for their WordPress installation if the path to their installation was to be changed. This is fixed now.

18) [Bug Fix] : Some links in the language strings were broken in Slovak, Hungarian, Polish, Czech translations. This is also fixed now.

19) [Bug Fix] : Auto backups were not performed for PERL scripts. This is now fixed.

20) [Bug Fix] : On the Edit Installation page, Users were shown an option to install the WordPress plugins which are disabled from Softaculous Admin Panel -> Software -> Advanced settings page. This is fixed now.

21) [Bug Fix] : Fixed a JavaScript bug in Themes Search option on WordPress install form.

We hope you like the new changes and we will be adding more features in the upcoming releases.

Regards,
The Softaculous Team

AMPPS 3.4

The Softaculous AMPPS Team has released AMPPS 3.4

This version of AMPPS adds the latest versions of PHP. We have also added new features and fixed some bugs in
AMPPS.

AMPPS is a LAMP (Linux), WAMP (Windows) and MAMP (Macintosh) stack of
Apache, MySQL, MongoDB, PHP, Perl & Python. AMPPS enables you to
focus more on using applications rather than maintaining them on your
desktops.

A complete list of changes:

The current version of AMPPS for Windows include:

Softaculous 4.6.9
Apache 2.4.18
PHP 7.0.2 Added, PHP 5.6.17, PHP 5.5.31, PHP 5.4.45 and 5.3.29
Ioncube Loader added for all PHP versions. 
PERL 5.16.3
Python 3.5.1 with mod_wsgi 4.21 module
MySQL 5.6.28
phpMyAdmin 4.4.15.1
SQLite Manager 1.2.4
MongoDB 3.2.0
RockMongo 1.1.7
FileZilla FTP Server 0.9.44

The current version of AMPPS for Mac include:

Softaculous 4.6.9
Apache 2.4.17
PHP 7.0.2 Added, PHP 5.6.17, PHP 5.5.31, PHP 5.4.43 and 5.3.29
Ioncube Loader added for all PHP versions.
PERL 5.22.0
Python 3.5.1 with mod_wsgi 4.21 module
MySQL 5.6.26
phpMyAdmin 4.4.15.1
SQLite Manager 1.2.4
MongoDB 2.6.7
RockMongo 1.1.7
Pure-FTPd Server 1.0.36

The current version of AMPPS for Linux include:

Softaculous 4.6.9
Apache 2.4.18
PHP 7.0.2 Added, PHP 5.6.17, PHP 5.5.31, PHP 5.4.45 and 5.3.29
Ioncube Loader added for all PHP versions.
PERL 5.22.2
Python 3.5.1 with mod_wsgi 4.21 module
MySQL 5.6.28
phpMyAdmin 4.4.15.1
SQLite Manager 1.2.4
MongoDB 3.2.0
RockMongo 1.1.7
Pure-FTPd Server 1.0.36

Regards,
The Softaculous AMPPS Team

AMPPS Softaculous 4.6.7 Launched

The Softaculous Team has released Softaculous 4.6.7 for AMPPS.

1) New Look : Softaculous Enduser Panel has been completely revamped and is now Responsive as well.

2) [Feature] : Added option in Softaculous Admin panel -> Settings to store database password for users’ installations in encrypted format. More details.
Note : This option requires “mcrypt” extension to be enabled.

3) [Feature] : Added auto upgrade support for Custom scripts.

4) [Feature] : Related Scripts will be displayed whenever you view a script.

5) Improved the installation upgrade page where the URL to complete the database upgrade is displayed to notify users of the required action.

6) Added option in Softaculous Admin panel -> Settings to choose the format for the date displayed in Softaculous.

7) Updated SMTP mailer library.

8) Added option in Softaculous Admin panel -> Settings to disable “Customize Theme” option for endusers. If this setting is enabled endusers will not be able to customize the theme e.g. Header color, Sidebar color, etc

9) Admin/Enduser can now disable email notifications for Restore installations.

10) Database Name option on the script install form has been moved to Advanced Options category.

11) Updated Italian Language.

12) Months in the date displayed by Softaculous will now be displayed in native language.

13) Added Languages : Chinese, Slovak, Polish and Czech.

14) [Feature] : Added option to choose protocol while importing an installation to Softaculous.

15) [Feature] : Added support for CRAM-MD5 with SMTP.

16) [Improvement] : Improved Softaculous API.

17) Added option in admin panel to disable protocols for endusers.

18) [Bug Fix] : Clone was unable to properly update the Foreign characters to the database of cloned installation. This has been fixed.

19) [Bug Fix] : Disallowed . (DOT) in Cookie Name option from Softaculous Admin panel because a . (DOT) is not allowed to be used as an array key in $_COOKIE in PHP.

20) [Bug Fix] : When there was an error while installing a script and the form was posted again, the language option had additional backslash (\) causing the install to fail. This has been fixed now.

21) [Bug Fix] : Update Software page in Softaculous Admin panel tried to update custom script package causing a JS error. This is fixed now.

We hope you like the new changes and we will be adding more features in the upcoming releases.

Regards,
The Softaculous Team

AMPPS 3.3

The Softaculous AMPPS Team has released AMPPS 3.3

This version of AMPPS adds the latest versions of PHP. We have also added new features and fixed some bugs in
AMPPS.

AMPPS is a LAMP (Linux), WAMP (Windows) and MAMP (Macintosh) stack of
Apache, MySQL, MongoDB, PHP, Perl & Python. AMPPS enables you to
focus more on using applications rather than maintaining them on your
desktops.

A complete list of changes:

The current version of AMPPS for Windows include:

Softaculous 4.6.3
Apache 2.4.12
PHP 5.6.11, PHP 5.5.27, PHP 5.4.43 and 5.3.29
Ioncube Loader added for all PHP versions. 
PERL 5.16.3
Python 2.7.10 with mod_wsgi 3.5 module
MySQL 5.6.25
phpMyAdmin 4.4.11
SQLite Manager 1.2.4
MongoDB 3.0.4
RockMongo 1.1.7
FileZilla FTP Server 0.9.44

The current version of AMPPS for Mac include:

Softaculous 4.6.3
Apache 2.4.12
PHP 5.6.11, PHP 5.5.27, PHP 5.4.43 and 5.3.29
Ioncube Loader added for all PHP versions.
PERL 5.22.0
Python 2.7.10with mod_wsgi 3.5 module
MySQL 5.6.25
phpMyAdmin 4.4.11
SQLite Manager 1.2.4
MongoDB 2.6.7
RockMongo 1.1.7
Pure-FTPd Server 1.0.36

The current version of AMPPS for Linux include:

Softaculous 4.6.3
Apache 2.4.12
PHP 5.6.11, PHP 5.5.27, PHP 5.4.43 and 5.3.29
Ioncube Loader added for all PHP versions.
PERL 5.22.2
Python 2.7.10 with mod_wsgi 3.5 module
MySQL 5.6.25
phpMyAdmin 4.4.11
SQLite Manager 1.2.4
MongoDB 3.0.4
RockMongo 1.1.7
Pure-FTPd Server 1.0.36

Regards,
The Softaculous AMPPS Team

 

Ampps 3.2 – PHP 5.6.10 RC1

With the help of this package you can start testing latest PHP 5.6 builds and report PHP Bug if any.

PHP Version : 5.6.10RC1

AMPPS is a LAMP (Linux), WAMP (Windows) and MAMP (Macintosh) stack of Apache,MySQL, MongoDB, PHP, Perl & Python. AMPPS enables you to focus more
on using applications rather than maintaining them on your desktops.

The current PHP Dev Package AMPPS 3.2-PHP 5.6.10RC1 for Windows, Linux and Mac Os X include:

Softaculous 4.6.3

Apache 2.4.12

PHP 5.6.10RC1, 5.3.29

PERL 5.16.3

Python 2.7.9 with mod_wsgi 3.5

moduleMySQL 5.6.23

phpMyAdmin 4.4.8

SQLite Manager 1.2.4

MongoDB 3.0.2

RockMongo 1.1.7

FileZilla FTP Server 0.9.44

Regards,
The Softaculous AMPPS Team

AMPPS 3.2

The Softaculous AMPPS Team has released AMPPS 3.2

This version of AMPPS adds the latest versions of PHP. We have also added new features and fixed some bugs in
AMPPS.

AMPPS is a LAMP (Linux), WAMP (Windows) and MAMP (Macintosh) stack of
Apache, MySQL, MongoDB, PHP, Perl & Python. AMPPS enables you to
focus more on using applications rather than maintaining them on your
desktops.

A complete list of changes:

The current version of AMPPS for Windows include:

Softaculous 4.6.3
Apache 2.4.12
PHP 5.6.9, PHP 5.5.25, PHP 5.4.41 and 5.3.29
PERL 5.16.3
Python 2.7.9 with mod_wsgi 3.5 module
MySQL 5.6.24
phpMyAdmin 4.4.6.1
SQLite Manager 1.2.4
MongoDB 3.0.2
RockMongo 1.1.7
FileZilla FTP Server 0.9.44

The current version of AMPPS for Mac include:

Softaculous 4.6.3
Apache 2.4.12
PHP 5.6.9, PHP 5.5.25, PHP 5.4.41 and 5.3.29
PERL 5.20.2
Python 2.7.9 with mod_wsgi 3.5 module
MySQL 5.6.24
phpMyAdmin 4.4.6.1
SQLite Manager 1.2.4
MongoDB 2.6.7
RockMongo 1.1.7
Pure-FTPd Server 1.0.36

The current version of AMPPS for Linux include:

Softaculous 4.6.3
Apache 2.4.12
PHP 5.6.9, PHP 5.5.25, PHP 5.4.41 and 5.3.29
PERL 5.20.2
Python 2.7.9 with mod_wsgi 3.5 module
MySQL 5.6.24
phpMyAdmin 4.4.6.1
SQLite Manager 1.2.4
MongoDB 3.0.2
RockMongo 1.1.7
Pure-FTPd Server 1.0.36

Regards,
The Softaculous AMPPS Team

 

AMPPS 3.1 – PHP 5.6.9 RC1

AMPPS 3.1-PHP 5.6.9RC1. Launched

With the help of this package you can start testing latest PHP 5.6 builds and report PHP Bug if any.

PHP Version : 5.6.9RC1

AMPPS is a LAMP (Linux), WAMP (Windows) and MAMP (Macintosh) stack of Apache, MySQL, MongoDB, PHP, Perl & Python. AMPPS enables you to focus more on using applications rather than maintaining them on your desktops.

The current PHP Dev Package AMPPS 3.1-PHP 5.6.9RC1 for Windows, Linux and Mac Os X include:

Softaculous 4.6.3

Apache 2.4.12

PHP 5.6.9RC1, 5.3.29

PERL 5.16.3

Python 2.7.9 with mod_wsgi 3.5 module

MySQL 5.6.23

phpMyAdmin 4.4.4

SQLite Manager 1.2.4

MongoDB 3.0.2

RockMongo 1.1.7

FileZilla FTP Server 0.9.44

Regards,
The Softaculous AMPPS Team

AMPPS Softaculous 4.6.3 Launched.

The Softaculous Team has released Softaculous 4.6.3

1) Minor UI changes for Softaculous Enduser panel.

2) Added support for WordPress themes installation option for custom WordPress packages.

3) Added options in Admin panel to Force/Enable Auto Upgrades for Enduser(s).

4) Users can now choose the files they want to backup when the installations is made in the root of their domain. The files can be chosen from “Edit Installation” page of the respective installation.

5) Bug Fix : All scripts were not selected when using “Select All” check box for selected categories in Softaculous Admin panel -> Software page

We hope you like the new changes and we will be adding more features in the upcoming releases.

Regards,
The Softaculous Team

AMPPS 3.1

The Softaculous AMPPS Team has released AMPPS 3.1

This version of AMPPS adds the latest versions of PHP, MySQL,
phpMyAdmin, MongoDB. We have also added new features and fixed some bugs in
AMPPS.

AMPPS is a LAMP (Linux), WAMP (Windows) and MAMP (Macintosh) stack of
Apache, MySQL, MongoDB, PHP, Perl & Python. AMPPS enables you to
focus more on using applications rather than maintaining them on your
desktops.

A complete list of changes:

The current version of AMPPS for Windows include:

Softaculous 4.6.3
Apache 2.4.12
PHP 5.6.8, PHP 5.5.24, PHP 5.4.40 and 5.3.29
PERL 5.16.3
Python 2.7.9 with mod_wsgi 3.5 module
MySQL 5.6.24
phpMyAdmin 4.4.4
SQLite Manager 1.2.4
MongoDB 3.0.2
RockMongo 1.1.7
FileZilla FTP Server 0.9.44

The current version of AMPPS for Mac include:

Softaculous 4.6.3
Apache 2.4.12
PHP 5.6.8, PHP 5.5.24, PHP 5.4.40 and 5.3.29
PERL 5.20.2
Python 2.7.9 with mod_wsgi 3.5 module
MySQL 5.6.24
phpMyAdmin 4.4.4
SQLite Manager 1.2.4
MongoDB 2.6.7
RockMongo 1.1.7
Pure-FTPd Server 1.0.36

The current version of AMPPS for Linux include:

Softaculous 4.6.3
Apache 2.4.12
PHP 5.6.8, PHP 5.5.24, PHP 5.4.40 and 5.3.29
PERL 5.20.2
Python 2.7.9 with mod_wsgi 3.5 module
MySQL 5.6.24
phpMyAdmin 4.4.4
SQLite Manager 1.2.4
MongoDB 3.0.2
RockMongo 1.1.7
Pure-FTPd Server 1.0.36

Regards,
The Softaculous AMPPS Team